Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN









Search Auto Parts

1997 Subaru Legacy - starts but immediately dies after IACV service


  Email This Post



twainband
Novice

Apr 1, 2022, 8:04 AM

Post #1 of 11 (617 views)
  post locked   1997 Subaru Legacy - starts but immediately dies after IACV service  

Hello

Yesterday: I pulled the IACV on my '97 Subaru Legacy in an attempt to solve a P0505. I cleaned and bench-tested the valve and it seemed to be operating just fine. I put everything back together, replacing a small bit of broken air hose that i discovered in the process. Have tripple checked that all harnesses were reconnected properly, giving them a clean with contact cleaner before hand.

Now: When i attempt to start the car, it fires up immediately (one problem i was chasing was a hard cold start, always took multiple tries). Engine runs at normal idle for a few seconds then steadily dies. When i give it gas to attempt to sustain the idle, it dies just the same but the engine shudders in a not so nice way.

My bluetooth OBDII reader, which was working fine before, is unable to connect to the car (probably because it is not running) so I don't have new codes... Since it's firing up, my feeling is it's probably a vacuum/air issue.. but what could have happened between the IACV test to cause this problem ?

I'm really up the creek here, if anyone could help me with suggestions or a test protocol, i would be really grateful ! don't have to drive to work til Tues but i'm anxious to get it running

thanks kindly
mat


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Apr 1, 2022, 8:11 AM

Post #2 of 11 (615 views)
  post locked   Re: 1997 Subaru Legacy - starts but immediately dies after IACV service  

Have you taken a reading on the fuel pressure?

Here is the spec

Fuel Pressure

With Regulator Disconnected .................... 34-38 psi (235-265 kPa)
With Regulator Connected .................... 26-30 psi (177-206 kPa)



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



twainband
Novice

Apr 1, 2022, 8:15 AM

Post #3 of 11 (612 views)
  post locked   Re: 1997 Subaru Legacy - starts but immediately dies after IACV service  

I haven't. Will do and post here


twainband
Novice

Apr 1, 2022, 10:01 AM

Post #4 of 11 (600 views)
  post locked   Re: 1997 Subaru Legacy - starts but immediately dies after IACV service  

ok. connected the fuel pressure meter between the filter and the fuel rail. i'm getting a reading of 30psi while the engine runs. when it dies, the meters briefly peaks at 40psi then drops to zero.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Apr 1, 2022, 1:04 PM

Post #5 of 11 (589 views)
  post locked   Re: 1997 Subaru Legacy - starts but immediately dies after IACV service  

Those are good pressures so we can eliminate the fuel supply system.

If your code reader stopped working, then you need to test all the fuses with a test light.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



twainband
Novice

Apr 1, 2022, 6:56 PM

Post #6 of 11 (576 views)
  post locked   Re: 1997 Subaru Legacy - starts but immediately dies after IACV service  

 Thanks so much for the speedy responses HT

I tested all fuses and they all passed.
While i was in there, checked the resistance of the ignition coil and the IACV... both read slightly higher than spec, but just like .3 ohm.

I'm wondering: is the gap in the IACV the culprit ? admitting too much O2? when it's "closed", there is still a 1/2" opening. I discovered that this can be adjusted by loosening the top screws and twisting the valve assembly in the housing... but i wasn't sure what the ideal spacing was so i just put it back the way I found it.. this car had been struggling to start in the mornings (usually took two or three tries) and very occasionally would stall out when down shifting (it's an automatic...).

thanks again for giving this your time... cheers m


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Apr 1, 2022, 7:05 PM

Post #7 of 11 (573 views)
  post locked   Re: 1997 Subaru Legacy - starts but immediately dies after IACV service  

Those IACs are not supposed to be adjusted.
Have you messed with the throttle plate adjustments?

My understanding is you have not tried another IAC, why not?



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



twainband
Novice

Apr 2, 2022, 7:50 AM

Post #8 of 11 (535 views)
  post locked   Re: 1997 Subaru Legacy - starts but immediately dies after IACV service  

I haven't tweaked the throttle plate yet... don't have any experience there. Any guidelines for how to go about that ?

I haven't tested a new IACV yet - it's a $200 part and mine appears to be funcioning correctly, according to voltage and bench test..


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Apr 2, 2022, 8:37 AM

Post #9 of 11 (527 views)
  post locked   Re: 1997 Subaru Legacy - starts but immediately dies after IACV service  

Just an "Out of the box thought/thing" is this seems to just shut off - right?
Try something: If you get it to stay running holding gas pedal or it does sometimes jiggle the key not really turn it but up + down then try to pull it out it shouldn't come out in "run" position ever. If that causes it to happen there's a problem there not so likely but the fight with this uncertain it's the funky things that are real tough would be ignition something + change direction this goes?


T



twainband
Novice

Apr 2, 2022, 9:28 AM

Post #10 of 11 (524 views)
  post locked   Re: 1997 Subaru Legacy - starts but immediately dies after IACV service  

Laugh

ooookk

i figured it out.
pretty embarrassing;
IVAC intake hose was disconnected at the main intake
not used to this setup and didn't catch it
sorry for wastin yalls time
thanks for the help


Tom Greenleaf
Ultimate Carjunky / Moderator
Tom Greenleaf profile image

Apr 2, 2022, 11:28 AM

Post #11 of 11 (518 views)
  post locked   Re: 1997 Subaru Legacy - starts but immediately dies after IACV service  

We all make oooops things no problem + glad you found it and it's fixed.

Closed out at solved ask either of us we can re-open it,

Tom







  Email This Post
 
 


Feed Button




Search for (options) Privacy Sitemap