Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN






98 Toyo Avalon Aftermarket Amp/Stereo Question


Search for (search options)
 



taraye308
New User

Jul 19, 2010, 3:24 PM

Post #1 of 2 (1883 views)
98 Toyo Avalon Aftermarket Amp/Stereo Question Sign In

1998 Toyota Avalon XL

I currently have an aftermarket Pioneer stereo installed in my car with a factory sub, amp and speakers(either 4 or 6). When the volume is all the way down there is a hissing sound, I was told this may be because I do not have a multichannel amp installed? How many channels are needed? I also want to install this no links allowed Eclipse AVN2210p GPS Navi/Stereo is there anything special I will need for optimal playback? This is what the Eclipse website recommends no links allowed


(This post was edited by Sidom on Jul 19, 2010, 8:08 PM)


jk306
User

Jul 20, 2010, 8:11 PM

Post #2 of 2 (1858 views)
Re: 98 Toyo Avalon Aftermarket Amp/Stereo Question Sign In

Your car is most likely equipped with a factory amplifier, powering your speakers and subwoofer. The hissing noise is probably signal feedback from the radio wiring, since the factory amplifier gets its signal from the stereo wiring. There is not much you can do to get rid of the hissing noise unless you change your amplifier to a aftermarket one and run new rca cables and speaker wires away from any other power source. Also, there really isn't anything special you need to install your Eclipse indash, besides for a good proper installation with the wires soldered and heatshrinked for a good secure connection.






 
 
 






Search for (options) Privacy Sitemap