Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN






2020 suburban new transmission and issues after install


Search for (search options)
 



apa09010
New User

Apr 4, 2024, 4:12 PM

Post #1 of 2 (8101 views)
2020 suburban new transmission and issues after install Sign In

recently had the transmission fail at 110,000 on my 2020 chevy suburban 5.3l. Had a gm dealer install a remanufactured transmission, i drove it for about 10 miles and it started having harsh shifting in lower gears and erratic rpm jumps. they claim its the valve body.
the sales invoice shows only 5 qts of fluid charged with the new transmission install, im assuming they didnt flush all the fluid with the new install(hence only 5 qts not 11). could this have caused the new transmission to act the way it is.


Hammer Time
Ultimate Carjunky / Moderator
Hammer Time profile image

Apr 4, 2024, 4:50 PM

Post #2 of 2 (8098 views)
Re: 2020 suburban new transmission and issues after install Sign In

Yes, if they didn't flush the system and replace the cooler you could easily have debris lodged in the valve body. Sounds like they really did a half ass job.

I would take it higher in the company to the Service manager (not service writer/advisor) and if he won't help, take it to the district area manager.

That is unless you refused these services.



~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We offer help in answering questions, clarifying things or giving advice but we are not a substitute for an on-site inspection by a professional.



(This post was edited by Hammer Time on Apr 4, 2024, 4:51 PM)






 
 
 






Search for (options) Privacy Sitemap