Main IndexAuto Repair Home Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN











Search Auto Parts

Car Stereo Repair Advice


(2148 posts in 669 threads)
AMSOIL Corporate Website



Sign up here!

  First page Previous page 1 2 3 4 5 6 7 8 9 10 ... 12 Next page Last page
    Subject Views Replies Last Post
Post with replies   Root post car tape deck spitting out tape 3516 2 Mar 18, 2010, 12:31 PM
(kenray)
Post with replies   Root post kenwood stereo works fine but volume cannot go higher than 10 1849 1 Mar 18, 2010, 12:28 PM
(kenray)
Post with replies   Root post PIONEER DEH P5050UB 3784 2 Mar 18, 2010, 12:23 PM
(kenray)
Post with replies Root post Jammed indash CD Player 2186 2 Mar 18, 2010, 12:19 PM
(kenray)
Post with replies   Root post How expensive would it be to fix my 2003 Honda, Accord EX 5 cd changer? 2756 3 Mar 18, 2010, 12:16 PM
(kenray)
Post with replies   Root post Removable front panel 2709 2 Mar 18, 2010, 12:12 PM
(kenray)
Post with replies   Root post Pioneer DEH doesn't turn on 2637 1 Mar 18, 2010, 12:10 PM
(kenray)
Post with replies   Root post CD Release 2104 2 Mar 18, 2010, 12:08 PM
(kenray)
Post   Root post Re: '05 Yukon - no sound from speakers (stock) 2431 0 Mar 17, 2010, 8:04 AM
Post with replies   Root post amp/subwoofer wiring 1955 2 Mar 2, 2010, 9:39 AM
(bluetjk75)
Post with replies   Root post 99 Monte Carlo 1770 1 Mar 1, 2010, 2:41 AM
(nickwarner)
Post with replies   Root post 1986 Ford Crown Vic speaker problem 2852 2 Feb 23, 2010, 6:20 PM
(DaGreatPanda)
Post with replies   Root post Radio/6 cd changer sometimes will not turn on 1588 1 Feb 23, 2010, 3:06 PM
(DrElectrics)
Post with replies   Root post Speakers hum with the rev of the engine. 4586 6 Feb 22, 2010, 6:07 PM
(nickwarner)
Post with replies   Root post Car Radio will not pick up distant stations 2659 1 Feb 17, 2010, 3:31 PM
(DrElectrics)
Post with replies   Root post Alpine Amplifier Problem 3282 2 Feb 10, 2010, 2:00 PM
(wes101382)
Post with replies Root post the car won't run now! 2889 2 Feb 1, 2010, 2:56 PM
(DrElectrics)
Post with replies   Root post my radio and rain not good 2200 1 Jan 17, 2010, 7:53 PM
(nickwarner)
Post with replies   Root post Some days the radio works, other days radio is off while speakers pops 2180 1 Jan 15, 2010, 8:41 PM
(Sidom)
Post with replies   Root post stero wont turn on 2177 1 Dec 26, 2009, 2:06 PM
(Sidom)
Post with replies   Root post 1997 toyota previa stereo water damage 2660 1 Dec 25, 2009, 5:01 PM
(Sidom)
Post with replies   Root post My radio hates my Burnt cds 1764 4 Dec 13, 2009, 5:35 PM
(steve01832)
Post with replies   Root post 2006 Gmc Radio 1982 3 Dec 4, 2009, 8:07 PM
(Sidom)
Post with replies   Root post Odd behavior from GM CD Changer 2492 2 Nov 21, 2009, 1:18 PM
(dixie4run)
Post with replies Root post Amp keeps shutting off 2958 5 Nov 20, 2009, 6:43 PM
(Loren Champlain Sr)
Post with replies This thread is locked   Root post Please read so we can help you 4368 1 Nov 14, 2009, 10:39 AM
(Tom Greenleaf)
Post with replies   Root post BMW 316i Stereo Code 3349 3 Nov 10, 2009, 2:49 PM
(Hammer Time)
Post with replies   Root post Radio seems to function but no sound 2863 3 Oct 30, 2009, 6:27 PM
(Loren Champlain Sr)
Post with replies Root post FM donot work 2084 4 Oct 25, 2009, 12:23 PM
(Loren Champlain Sr)
Post with replies   Root post CAR CD PLAYER PROBLEMS!!!! 2994 1 Oct 4, 2009, 9:41 AM
(bruceglaser)
Post with replies   Root post Sound cuts out whilst driving- works fine early in the 3495 1 Oct 2, 2009, 6:53 AM
(thecarkeeper)
Post with replies   Root post Car stereo making ticking sound help plz 7147 5 Sep 13, 2009, 12:34 PM
(wayne28307)
Post with replies   Root post 2006 Kia Rio Radio 6063 3 Sep 5, 2009, 4:44 AM
(clipentertainment)
Post with replies   Root post car antenna 1807 1 Sep 5, 2009, 1:37 AM
(Hammer Time)
Post with replies Root post New ignition in 94 Accord causes stereo to lose power. 2190 4 Sep 4, 2009, 2:07 PM
(Sidom)
Post with replies   Root post Strange problem with wiring new CD Player 2579 1 Aug 31, 2009, 2:18 PM
(Sidom)
Post with replies Root post GM 2059 1 Aug 27, 2009, 9:09 PM
(Hammer Time)
Post Moved   Root post Moved: Weird speedometer thing - - Aug 26, 2009, 7:36 AM
Post   Root post Radio readout not working 3252 0 Aug 26, 2009, 7:31 AM
Post This thread is locked Root post FM Radio 1983 0 Aug 23, 2009, 5:33 AM
Post   Root post 2005 Pontiac G6 cd changer error 4464 0 Aug 22, 2009, 6:52 AM
Post with replies   Root post car radio short 2898 1 Aug 17, 2009, 12:52 PM
(Loren Champlain Sr)
Post with replies   Root post cd player 2621 1 Aug 16, 2009, 10:27 AM
(Guest)
Post This thread is locked Root post Radio will play CD for about 20 seconds and then says error-02 1929 0 Aug 16, 2009, 10:23 AM
Post with replies   Root post 1995 VW jetta gl 1726 1 Aug 16, 2009, 7:17 AM
(Sidom)
Post with replies   Root post tuner knob not working 1786 2 Aug 15, 2009, 12:11 PM
(korben)
Post   Root post 1997 bmw 328i radio swap 1897 0 Aug 12, 2009, 1:10 AM
Post with replies Root post 2003 Silverado AM Radio Noise 1917 1 Aug 12, 2009, 12:11 AM
(Hammer Time)
Post   Root post The radio seems to work; the speakers do not? 2723 0 Aug 11, 2009, 1:01 PM
Post with replies   Root post 1998 Dodge Ram 2500 Speakers go in and out 5764 4 Aug 5, 2009, 9:06 PM
(Hammer Time)
Post with replies   Root post FRONT SPEAKER PROBLEMS 3390 3 Aug 5, 2009, 9:05 PM
(Hammer Time)
Post with replies Root post Car Audio Volume Problem 12020 5 Aug 5, 2009, 1:43 PM
(Loren Champlain Sr)
Post   Root post 1999 BMW Radio Issues 1906 0 Jul 30, 2009, 10:49 AM
Post with replies   Root post cd player 4155 4 Jul 26, 2009, 12:18 PM
(Loren Champlain Sr)
Post with replies   Root post Re: 95 Civic Radio/Tape Deck Problems 2997 1 Jul 25, 2009, 4:10 AM
(Guest)
Post   Root post 2005 Honda Accord Aux Installation 3202 0 Jul 24, 2009, 11:54 PM
Post   Root post blaupunkt max volume issue 1790 0 Jul 17, 2009, 4:57 PM
Post with replies   Root post 2004 T. Corolla, All speakers stopped working at once 3319 1 Jul 14, 2009, 10:06 AM
(Hammer Time)
Post with replies   Root post How do you remove a knob? 1897 1 Jul 13, 2009, 10:33 AM
(Loren Champlain Sr)
Post Moved Root post Moved: 2000 Pontiac Sunfire 5 spd. std.escessive gas use (pollution hoses) - - Jul 9, 2009, 7:34 AM
  First page Previous page 1 2 3 4 5 6 7 8 9 10 ... 12 Next page Last page


LEGEND
Hot thread = Hot thread
Post with replies = Post with replies
Single post = Single post
Post moved = Thread moved
Thread locked = The thread is locked
Root post = First post in thread


FORUM RULES
You cannot start new threads
You cannot post replies
 


Feed Button




Search for (options) Privacy Sitemap